sabato 22 novembre 2014

Brief guide to Clover EFI Yosemite on Asus P8H67-V - Sandy Bridge - HD3000 iGpu

My specs: Asus P8H67-V , i7-2600k, HD3000, Samsung 840 EVO SSD

0 - create or download an USB stick with Yosemite and Clover bootloader:

     - download latest clover version and put it into your USB;

     - download clover configurator and put it into your USB;

     - download kext wizard and put it into your USB;

     - download DSDT editor for MAC and put it into your USB;

     - download latest AtherosL1cEthernet.kext and put into your USB;

     - download GenericUSBXHCI_1.2.7_for_Yosemite_14A329r and put into your USB;

     - download fakesmc latest version and put it in your USB.

1 - you need to patch your bios to remove MSR limitation or you won't get native power management, google uefi tool / uefi patch;

2 - extract your DSDT with DSDT editor from Windows and save it to your USB;

3 - install Yosemite from UEFI USB (press F8 at boot and choose UEFI: USB (your model), select install osx from usb:

     - go to boot options and put 0x01268086 in device id for HD3000 (it will enable HW acceleration);

     - first passage format your disk with disk utility and install to your newly formatted disk;

     - at reboot boot from uefi USB again, go into options again and put 0x01268086 in device id for HD3000, chose install from usb again;

     - at next reboot boot from uefi boot, put again the device id in HD3000, select boot osx from disk (the one where you installed it)

4 - finalize installation with your data, don't choose automatic time zone. Put it manually.

5 - you should be at desktop, time to intall clover into UEFI, openup latest clover version and install it to your disk

   - install for UEFI only, install in esp, choose a theme don't select emuviariableuefi-64 and osxlowmemfixdrv in drivers, install rc scripts to target volume, optional clover preference panel;

   - put fakesmc into EFI/CLOVER/kexts/10.10 (create the directory)

6 - reboot from USB and open uefi shell:

   - find your efi partition with fsx: (fs1: , fs2: whatever is yours, check with ls what is the content)

   - when your found yours do cd \EFI\CLOVER ; bcfg boot dump ; bcfg boot add 0 CLOVERX64.efi "OSX"

7 - reboot, press F8 and choose boot from EFI:OSX (the option we just added)

8 - put the device id for HD3000 as in the previous passages to get HW acceleration

9 - time to setup hardware: 

     - open kext wizard and install atheros driver and USB 3.0 driver from your USB, repair permissions and cache;

     - open clover configurator, mount efi, import config.plist from efi, choose kext dev mode in boot options and -v (to see what’s going on), put 0x01268086 into devices under intel.

     - reboot

     - download and run —> (check info there).

     - put your SSDT.aml into EFI/CLOVER/ACPI/patched (mount efi with clover configurator)

     - open DSDT editor (download java), open your DSDT and apply toledo patch —>

     - I also applied from DSDT editor EHCI, LPC and Orange External Icons patches, compile the DSDT, google how to remove errors. Once you are set save the DSDT.aml to EFI/CLOVER/ACPI/patched

     - patch audio (realtek) —>

     - open clover configurator remove all fixes and table dropping, don’t generate ssdt nor p-states or c-states, remove id for hd3000 in devices, remove orange icon
       patch from kernel and kext patches, choose your macmini5,1 smbios, inject kexts and system id in System Parameters

     - export plist to your EFI partition

     - reboot, that’s it

     - if you have SSD enable trim --> http://www.insanelym...-non-apple-ssd/

     - if you have the external monitor seen as TV through HDMI (bad colors) use this RGB override fix and calibrate your monitor color scheme --> http://www.ireckon.n...xternal-monitor
     - for wifi I use a digicom wave 150c (RT2870) with these kexts -->http://www.mediafire...4_UI2.6.4.0.dmg

turbo boost video

lunedì 5 maggio 2014

Simple Proof IOS 7.1.1 causes faster battery drain

I have an iphone 4 16Gb and my gf has a 4s 16Gb, after upgrading from ios 7.1 to ios 7.1.1 I noticed faster battery drain. 

I did a search on google and found suspicious articles about better battery life on the latest fw.

Needless to say those articles are all followed by comments of users which tell the exact contrary.

For example zdnet writes:  "iOS 7.1.1 brings with it better iPhone battery life"...

while users comments are like this: "Battery life is dramatically worse after iOS 7.1.1 on iPad - I've never had any problem with battery life with any iOS on my iPad. Since updating to 7.1.1 however, I noticed a massive drain on battery life.... almost a 50% drain overnight (from 100% to 55%) while not being used and today while being used, a dramatically fast drain in battery life every few minutes."

So what's going on here?

I was fast enough to revert my iPhone to 7.1 using iTunes and a signed 7.1 IPSW file and guess what? 

Battery drain disappeared.

My gf for instance refused to go back and kept iOs 7.1.1 even if she had notice the battery drain issue.

These two phones had their battery changed in the same day with new identical blue-star ones 2 months ago.

Now please take a look at these screenshots, the first is from my iPhone 4 reverted to ios 7.1 while the second is from the iPhone 4s with ios 7.1.1. 

Both phones were charged to 100% from zero.

As you can see I got 6% battery life from 100% with a standby time of one day (24 hours) and usage of 6:32 hours.

Now to my gf one:

While she had same 6% more battery life her standby time from 100% to 6% was of only 12:35 hours and usage time of 4:38 hours.

That's make a terrible ios 7.1.1 battery performance, it's only 52% circa of standby time and 70% of the usage time of my iPhone 4, she had more or less my same performance before upgrading to ios 7.1.1.

The use of the phones is similar (whatsapp, browing, messaging and little calling).